Решение: GPSPhotoLinker не работает в OS X Mavericks (10.9)

Обновление на OS X Mavericks приводит к тому, что приложение GPSPhotoLinker для пакетной вставки геотегов в фотографии перестаёт работать.
Решение было найдено на форуме Early Innovations.

GPSPhotoLinker
Вид окна GPSPhotoLinker

Дело в том, что GPSPhotoLinker требует Perl версии 5.10, который уже не поставляется с OS X Mavericks, поэтому его нужно установить самостоятельно:

1. Копируем Perl 5.10 с компьютера под управлением OS 10.7, 10.8 из директории /System/Library/Perl/5.10/, либо качаем отсюда.
2. Переносим Perl 5.10 на мак под управлением 10.9 в папку /System/Library/Perl/5.10
3. В терминале создаём ссылку:
cd /System/Library/Perl
sudo -s
mkdir lib
mkdir lib/5.10
ln -s /System/Library/Perl/5.10/darwin-thread-multi-2level/CORE/libperl.dylib /System/Library/Perl/lib/5.10/libperl.dylib

4. Готово!

Решение: GPSPhotoLinker не работает в OS X Mavericks (10.9): 1 комментарий

  1. После апгрейда до OS X 10.11 El Capitan копирование старого Perl в системную директорию усложнилось из-за защиты на уровне операционной системы.

    Перед тем, как скопировать Perl, перезагружаемся в режим восстановления, удерживая cmd — R
    Затем открываем терминал и вводим команду:
    csrutil disable
    Перезагружаемся и копируем Perl, как написано в посте.
    После копирования Perl неплохо вернуть назад системную защиту, перезагрузившись в режим восстановления и введя в терминале
    csrutil enable

Добавить комментарий